logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

naveenl
#1 Posted : Thursday, December 4, 2008 10:40:05 AM(UTC)
naveenl

Rank: Newbie

Groups: Member
Joined: 12/4/2008(UTC)
Posts: 1

I am unable to use GVT in my application. The error is:

"Unknown server tag ''GVT:GridViewTree"

Here are the steps I have followed:

1. I have installed the GridViewTree.msi
2. Added "GridViewTree.dll" reference to the project.
3. Added this line to aspx page.
"<%@ Register Assembly="GridViewTree" Namespace="GridViewTree" TagPrefix="GVT" %>".
4. Added this code to aspx source.

<GVT:GridViewTree ID="GridViewTree1" runat="server" AllowSorting="True" AutoGenerateColumns="False" EnableViewState="False" FullPathDataColumn="FullPath"
IsParentDataColumn="IsFolder" OnRowCreated="GridViewTree1_RowCreated" ParentLevelStartSortByColumn="0">
<Columns>
<asp:BoundField DataField="FullPath" HeaderText="SalesPerson" SortExpression="FullPath">
<itemstyle wrap="True" />
</asp:BoundField>
<asp:BoundField DataField="CustomerID" HeaderText="Customer" SortExpression="CustomerID">
<itemstyle horizontalalign="Right" />
</asp:BoundField>
<asp:BoundField DataField="OrderDate" HeaderText="OrderDate" SortExpression="OrderDate">
<itemstyle horizontalalign="Right" />
</asp:BoundField>
<asp:BoundField DataField="UnitPrice" DataFormatString="{0:c}" HeaderText="UnitPrice"
SortExpression="UnitPrice">
<itemstyle horizontalalign="Right" />
</asp:BoundField>
<asp:BoundField DataField="Quantity" HeaderText="Quantity" SortExpression="Quantity">
<itemstyle horizontalalign="Right" />
</asp:BoundField>
<asp:BoundField DataField="Total" DataFormatString="{0:###,##0}" HeaderText="Total"
SortExpression="Total">
<itemstyle horizontalalign="Right" />
</asp:BoundField>
</Columns>
</GVT:GridViewTree>


Then it is throwing the error.

Is there anything that I should do to make it work?
Support
#2 Posted : Thursday, December 4, 2008 12:59:14 PM(UTC)
Support

Rank: Administration

Groups: Member
Joined: 4/3/2008(UTC)
Posts: 43

The registration line that you used is an older one??
The registration should be:
<%@ Register assembly="GridViewTree" namespace="DigitalTools" tagprefix="DT" %>
And then
<DT:GridViewTree ....
</DT:GridViewTree>
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.6.1 | YAF © 2003-2020, Yet Another Forum.NET
This page was generated in 0.072 seconds.